AB模板網:專注于dede模板,織夢源碼,織夢模板,網站模板,dedecms模板,網站源碼,dedecms教程以及各類手機網站模板和企業網站模板分享.
用戶名:
密碼:
注冊

織夢模板

網站模板搜索
VIP

Discuz!應用中心安裝模板提示版本號不匹配的解決方法

www.amuosk.icu / 2015-12-31
有時候我們從應用中心安裝模板,在應用中心里模板作者設定允許我們的程序版本,但是我們安裝時卻提示版本號不匹配,那這是為什么呢?經過我們分析發現是因為X3和X3.1,X3.2的模板是完全兼容的,很多模板是在X3的時候發布,而且之前的機制里一直是即使版本號不同,用戶依然可以強制安裝,但是,從X3.1后期開始,官方自己把自己的規矩改了,用戶沒有辦法強制安裝了,很多作者也沒有在意這點,而且應用中心模板的審核與發布、更新的周期更讓作者們苦等。
下面我們以discuz! X3的qing模板安裝在X3.2上為例子講解。
首先說的是錯誤提示圖,如下圖所示,官方發布的升級版版本號還是X2.5的,不過這不影響我們演示:

Discuz!應用中心安裝模板提示版本號不匹配的解決方法
我們打開template/qing(其他模板為其他模板的目錄)/discuz_style_qing.xml文件,在里面找到X2.5,
如果錯誤圖提示為什么版本就搜什么版本,通常能搜索到至少兩處
修改成自己的版本然后保存,重新在后臺,界面,風格設置處安裝模板即可。
本文由AB模板網:織夢模板整理發布,轉載請說明出處:http://www.amuosk.icu
首頁 免費模板 VIP專區 會員中心
收縮
和值大小单双玩法